May 2, 2018

In order to ensure the best customer experience with our limited resources, we have decided to support only macOS 10.12 (Sierra) and later (High Sierra), starting with NoteTaker 4 and NoteShare 4.  End of life (EOL) software version and platform decisions are never easy but we're committed to delivering quality software this summer. 

Please reload

Featured Posts

Update on Development Status

February 23, 2020

1/10
Please reload

Recent Posts

January 1, 2020

October 21, 2019

October 11, 2019

September 26, 2019

September 19, 2019

September 11, 2019

September 9, 2019

Please reload

Archive
Please reload

Search By Tags
Please reload